Problem

Seit den Updates von Google Chrome und Microsoft Edge ab Version 147.x.x kann es vorkommen, dass Signaturpads in Webanwendungen nicht mehr erkannt werden oder keine Verbindung aufgebaut wird.


Ursache

Die Browser haben neue Sicherheitsmechanismen eingeführt (Local Network Access / Private Network Access).

Diese verhindern, dass Webseiten automatisch auf lokale Dienste (z. B. Signaturpads über localhost/WebSocket) zugreifen.

  • Webseiten müssen jetzt explizit vom Benutzer freigegeben werden
  • Ohne Freigabe wird die Verbindung blockiert
  • Ab Version 147 betrifft das auch WebSockets (z. B. Pad-Kommunikation)


Hintergrund:
Diese Änderung dient dem Schutz vor Angriffen auf lokale Geräte (z. B. Router oder andere lokale Services).

Wichtig:
Dieses Verhalten tritt erst ab Version 147 auf.


Lösung 1: Zentrale Freigabe per Gruppenrichtlinie (empfohlen)

Wir empfehlen in Unternehmensumgebungen die zentrale Konfiguration per GPO.


Microsoft Edge

Registry-Pfad:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge\LocalNetworkAccessAllowedForUrls

Wert:


Google Chrome

Registry-Pfad:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\LocalNetworkAccessAllowedForUrls

Wert:


Hinweis:

  • Bei On-Premise-Installationen muss hier die URL Ihres eigenen Servers eingetragen werden (nicht universal.signosign.com).
  • Nach der Änderung ist ggf. ein Neustart des Browsers oder Systems erforderlich.  


Lösung 2: Website-Berechtigungen zurücksetzen und neu erlauben

Für Einzelarbeitsplätze kann die Freigabe auch manuell erfolgen.


Google Chrome

  1. Chrome öffnen
  2. In die Adressleiste eingeben:
    chrome://settings/content/all
  3. Nach der betroffenen Website suchen
  4. Eintrag öffnen und „Daten löschen“ auswählen
  5. Website neu laden
  6. Alle erscheinenden Berechtigungsanfragen zulassen

Alternativ:

  • Schloss-Symbol in der Adressleiste klicken
  • „Website-Einstellungen“ öffnen
  • „Lokales Netzwerk“ auf „Zulassen“ setzen


Microsoft Edge

  1. Edge öffnen
  2. In die Adressleiste eingeben:
    edge://settings/content/all
  3. Website suchen
  4. „Daten löschen“ auswählen
  5. Website neu laden
  6. Alle Sicherheitsabfragen zulassen