Symptom:
Bei der Erfassung einer neuen Unterschrift kann es zu einer Fehlermeldung kommen, welche über ein abgelaufenes Signaturzertifikat informiert.
Bei älteren Versionen kann diese Fehlermeldung ggf. auch "Das Einbringen der Unterschrift in das Dokument ist fehlgeschlagen. Grund: _GetPublicKeyInfoMemory_ for PFXPublic failed!" oder "Das Einbringen der Unterschrift in das Dokument ist fehlgeschlagen. Grund: GetPublicKeyInfoMemory failed!" lauten.
Ursache:
Bei der Erstellung von Zertifikaten muss ein Ablaufdatum für die Gültigkeit angegeben werden. Das Signaturzertifikat, welches mit signoSign/2 bis zur Setupversion 10.10.5 ausgeliefert wurde, ist bist zum 21.07.21 gültig. Ein neues Zertifikat muss erstellt und konfiguriert werden, damit signoSign/2 weiterhin verwendet werden kann.
Lösung:
Sie haben die Möglichkeit Ihr Zertifikat jederzeit selbst zu erneuern. Das geht unter: Extras > Konfiguration > Signatureinstellungen -> Zertifikateinstellungen > Zertifikat für Adobe DigSig-Signaturen
Dieser Vorgang ist auch noch einmal detailliert im Handbuch unter Kapitel 2.4.4 beschrieben. Sie können das Handbuch aus signoSign/2 aufrufen oder von unserer Produktseite auf unserer Webseite.
Sollten Sie ggf. auch die Fehlermeldung "Das Einbringen der Unterschrift in das Dokument ist fehlgeschlagen. Grund: _GetPublicKeyInfoMemory_ for PFXCryptBio failed!" erhalten, muss zusätzlich auch das Zertifikat für biometrische Daten erneuert werden.
Wichtig: Das Zertifikat, welches Sie dort generieren ist technisch identisch und nicht „schlechter“ als jenes, welches wir im Standardpaket mitliefern!
Alternativ können unsere Techniker dies als Dienstleistung auch über Fernwartung für Sie durchführen. Schicken Sie uns diesbezüglich die ausgefüllte Kostenübernahmeerklärung zu.