Symptom:


When sharing a document, the software displays the following error message:


"Sending the document to the server or creating the “sharing case” has failed. Details: Error converting value "CLICK" to type 'signotec.signoSign2.Base.Ssu.SigningMethod'. [...]"



Cause: 


The error occurs when sharing a document if the following software constellation is present:


  1. signoSign/2 version 11.11.2 (or older) is used.
  2. signoSign/Universal version 3.24.0 (or newer) is used.
  3. The “Click to Sign” signing method is activated.



Solutions:


There are two ways to solve the problem described above:


Solution 1: Software Upadte


Update signoSign/2 to version 11.11.3 or newer. You can obtain the current version via the download form.

Please note that software updates are only free of charge for licenses with an active software maintenance contract. For licenses without software maintenance, a chargeable update must be purchased before installation.



Solution 2: Disable "Click to Sign"


Cloud: As a cloud user, you can deactivate the “Click to Sign” signing method in the signoSign/Universal settings as follows:

  1. Login at https://universal.signosign.com/

  2. Switch to the user settings via the user symbol (top right).

  3. In the “Allowed signing methods” area, deactivate the “Click to Sign” method.

  4. Save the settings.

On-Premises: As an on-premises user, you can deactivate the “Click to Sign” signing method as follows:


  1. If user settings are activated, deactivation can be deactivated as described under “Cloud” by logging into the web portal.

  2. If user settings are deactivated, the signing method can be deactivated via the server-side setting “web.supportedCaptureInput” by removing “CLICK” as a method in the list.